9

I can't figure out how to flash the firmware found on http://www.electrodragon.com/w/ESP8266_AT-Command_firmware. I am using ESP8266 Download tool v3.4.4. When I am adding a firmware in download path it goes on till a fixed percentage (77 or 99..mostly) and gives the error Invalid head of packet, FAST FLASHING ERROR. One more thing is that the tutorials I am using to do this have many download path entries filled in the download tool while mine are just blank. It says upload the combined file to 0x0000. I tried uploading V1.54... file's content (both files) but still got the similar error.

enter image description here

So anyone could just guide me through this as I am a complete newb into this. Please mention any other information needed in comments.

PS

  1. I am pretty sure the power supply is adequate as I have been using esp8266 with the old firmware smoothly. I have also connected a 200uF capacitor b/w gnd and vcc(3.3v from FTDI).
  2. I have double checked the connections.(Yes, GPIO0 is grounded).
  3. I flashed an earlier version successfully ai-thinker-v1.1.1.bin but when I connected it to arduino IDE serial monitor it started giving unending gibberish text :P.
  • 1
    What is the flash size of your ESP? – Bence Kaulics Mar 11 '17 at 9:25
  • Not sure, but it says 32 bit MCU – Salim Shamim Mar 11 '17 at 9:34
  • I was silly it is on the picture. 8Mbit. – Bence Kaulics Mar 11 '17 at 12:36
  • I was having the same problem and just changed the BAUD rate deoim 115200 to 230400 and it flashed the firmware without errors. – Angel Ortiz Jun 26 '17 at 20:51
  • you do realise you've set two files to load to the same address, right? – Jaromanda X Feb 21 '18 at 0:16
6

Configuration that worked for me

Okay found the solution.

  1. Firstly I think the detected info block tells the flash size. In Snap it could be seen as 8MBit.
  2. The 1.54 version of the firmware has two files, one for 8Mbit and the other for 32Mbit.
  3. I went for 8Mbit and checked both SpiAutoSet and DoNotChgBin, and volla. It was succesful this time.
  4. I set the baudrate to maximum (1500000) not sure though if it's necessary.

PS: Please help improve the answer by mentioning any important information I need to mention in the answer or If anything is wrong.

|improve this answer|||||
  • 1
    In effect, @Bence was right then. I don't know the toolchain, is there anything you can edit in your answer to make it more useful for someone else with a similar problem - such as a screenshot of where you see the flash size? – Sean Houlihane Mar 11 '17 at 10:25
  • Added it @SeanHoulihane – Salim Shamim Mar 11 '17 at 10:35
  • I believe baudrate is usually 115200, not sure though. – Bence Kaulics Mar 11 '17 at 15:46
  • 1
    Note that you can mark your answer as accepted by clicking on the tick beside it. – Bence Kaulics Mar 13 '17 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.