5

This article is not device specific, but rather is focused on using sdptool and rfcomm to setup a serial com port connection over bluetooth. If you have another method instead of these two Linux modules that is welcomed as well! My specific example uses the Intel Joule, but alternative devices can still use sdptool and rfcomm. Please feel free to explain for an alternative device that you have experience with, it may help me resolve a similar issue using Joule.

Introduction: I am currently trying to create a COM port connection between my PC and the Intel Joule platform. I have been able to do it with a cord but I would like to control it over Bluetooth. I've already paired the device with my computer and am currently following this tutorial:

https://software.intel.com/en-us/node/721513

Background for personal IoT system: I need to be able to create this serial connection over the Bluetooth port so that I can wirelessly collect data and store it to my local SQL. It would have to allow machines communicating as I want the data collection process to run completely autonomously. And I want an AI either on the joule or running through my client to use this data then run specific commands on the joule wirelessly through a serial Bluetooth connection. This type of serial connection through Linux base using sdptool is used in many devices such as the Arduino and the Joule. Even if you do not have experience with the joule but do have experience setting up a COM serial connection over Bluetooth, it will likely be very helpful for me to understand how to establish the serial connection over Bluetooth. If you have managed to acquire the connection with an alternative device lease share the information, it could allow me to use that same train of thought on the Joule.

Current Linux porting process and progress:

I am able to add a serial port with:

sdptool add SP

But when I run rfcomm to watch to port using:

rfcomm watch hci0 1 getty rfcomm0 115200 vt100 -a root

I receive this:

RFCOMM TTY layer initialized
RFCOMM socket layer initialized
RFCOMM ver 1.11
Waiting for connection on channel 1

From there I return to my PC's Bluetooth settings and traverse to COM Ports (none show up). SO I click Add... and I've tried both Incoming and Outgoing connection (choosing the paired joule device). The result is this error:

The device you selected does not have a serial port service running

... but I mean in the device it's saying

"waiting for connection on channel 1"

  • 8
    I was literally just told it wasn't acceptable as a stack overflow question. What do you think the intel joule is used for? It's an IoT platform. Please instead of preventing me from receiving help allow the question to stand. I require my Joule device to be remote written through a Bluetooth serial port as I can't pull it out of my IoT system every time. I really don't understand the reason for this block. I'm pulling out my hair moving from help site to help site just for people to say, "It's not relevant". I was told to come here and now I receive nothing once again. :( – Sam H. Jun 21 '17 at 5:58
  • 2
    Please give me an explanation or at very minimum a redirection to the correct help site. As far as I'm concerned this is exactly the site to help me out! – Sam H. Jun 21 '17 at 6:00
  • 2
    I should have put IoT in the title, maybe then it would be "relevant". Sorry, I'm just frustrated. I understand you are here to help facilitate the site and I appreciate that. – Sam H. Jun 21 '17 at 6:01
  • 3
    Sam, I am sorry that I can't help you. This seems like an acecptable question to me, but you might try asking on communities.intel.com/community/tech/intel-joule – Mawg Jun 21 '17 at 7:27
  • 5
    The scope of this question is either setting up a bluetooth channel from a device to your PC, (which is my guess) or in sending serial data from the endpoint to it's bluetooth channel. Either way, I think it's quite specific to the device. So whilst it could be on-topic here, I the manufacturer forums are more likely to be effective. EE.SE would be the other possibility, but i don't think there is enough information here to get a generic diagnosis. – Sean Houlihane Jun 21 '17 at 21:32

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.