2

Today, I moved my Chromecast from one room to another, and when I tried to connect, my phone couldn't find it. I did a factory reset, but now I still can't find the Chromecast on either my laptop or my phone. This is so bizarre because when I initially set up the Chromecast, I was able to connect with no problem. When I go to edit my router settings at myfiosgateway.com, I can also see the Chromecast in the network. Does anyone know what might be causing this problem and how to fix it? Was doing the factory reset a bad idea?

5

Here are a few possibilities from whistleout.com:

1. Factory data reset (FDR)

Looks like you already tried this, but included for reference. A factory reset is the easiest fix, and frequently can resolve a lot of issues

2. Reset your modem/router

Unplug both your modem and your router (if they are separate devices). Leave them unplugged for a bit, then re-plug them back in, modem first, router second, if they are separate. Wait a minute or so before trying to connect the chrome-cast.

3. Use an extender

If the chromecast is sitting behind the screen, it can be a good idea to use an HDMI extender to bring it out from behind the screen. This will give it a better clear path to the router and a cleaner signal.

4. Move your router

Basically the same idea: if the signal isn't reaching, it could be a good idea to move your router closer to the chromecast. You mention that you changed the room it was in, so it's not impossible that the signal isn't reaching as well as before.

5. Make sure your network operates at 2.4GHz

I'm assuming this isn't the issue, since it was working fine before, but including for reference. If your router has both the 5GHz and 2.4GHz possibilities, you'll have to select the 2.4GHz on your Chromecast.

6. Make sure your router firmware is up to date

Outdated router firmware could cause issues. Even if it isn't, updating it will help close up security leaks.

7. Adjust router channels

Most routers come set to automatically set a channel. If this is the case on your router, change it to a numbered option: there could be interference between your automatically selected frequency and a neighbor's, for instance. More info is on the linked page.

1
  • Thanks! So I have no idea what happened, but it's working now. I had already done a factory reset on my chromecast several times, and I was using it in the exact same place I'd used it for several months.
    – matt_js
    Sep 15 '17 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.