4

I have a projector (JVC x5500) which is stupid. It blocks remote control input for several seconds when the HDMI signal changes. So I need the AVR and HTPC to turn off after the projector. There for I have put it first in the list

Logitech Harmony Configuration

But my Harmony does not wait for the Projector to finish. It shuts down the AVR right away blocking my projector from shutting down.

I tried to explicitly do the shutdown sequence and then add a wait. But it turns out that the Harmony app filters away the shutdown buttons.

Harmony configuration with value dropdown clicked

2
  • You could also shut down the projector first, right? – Helmar Dec 11 '17 at 12:37
  • Thats what I am trying todo – Anders Dec 11 '17 at 13:12
2

A bit of research seems to indicate that it's status by design. Check out here on their support website: they say:

If a device is not turning on or switching inputs correctly, you may need to adjust your inter-device delay. The inter-device delay is how long Harmony waits after sending a command to one device, before being able to send a command to another.

This indicates that the Harmony is designed such that it sends commands not after the command has been completed, but rather after the command has been sent. Unfortunately, this means that though it sends the command to turn off your AVR after sending the command to turn off your projector, the projector has not completed its turn-off sequence, and the AVR already begins to shut down.

To resolve the issue, you'll probably have to figure out how long it takes for your projector to turn off, and add a delay (with the button at top right) equal or greater than the longest time you would expect the projector to take to turn off.

4
  • You mean add a delay to teh AVR and media PC shutdown commands? Because thats what I have done. And it works. But its an ugly work around. Becase its on a device level. So If I have another activity without the projector it will stil use the delay for the AVR and media pc even if not needed. I tried to increase the inter device delay on the projector. Did not help. Teh AVR is shutdown immediately – Anders Dec 11 '17 at 13:57
  • @Anders, interesting. I don't actually have a Harmony Hub with me presently, but to confirm: if you set the delay using the button labeled Add Delay in your image, it doesn't actually add a delay between shutoff commands: it adds it to a specific device? – anonymous2 Dec 11 '17 at 14:01
  • If you talk about my screen its the activity shutdown command list. Here you can for some reason behond me only add a delay at the top of the list. Not between device shutdown commands.Only way I have found is to add delay to teh AVR shutdown command list so it does not trigger while the projectors command are sent. Whiich is all backward since I can use the AVR without the projector. THe delay should be configured in conjunction with using the projector, but I cant see how that would be done – Anders Dec 11 '17 at 14:09
  • Oh, yuck. That's no fun. I'll glance around, but looks like my answer may be useless if that's the case. – anonymous2 Dec 11 '17 at 14:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.