7

I have an AWS IoT button (2nd Gen) that I am able to successfully connect to a portable hotspot and send notifications through, but when I try to reconfigure the button to run on a Wi-Fi network, I keep getting a short long short red light pattern.

Here is the AWS explanation for the error:

There was an error performing the host name lookup. This can be the result of not being able to reach the DNS server or an incorrectly configured AWS IoT endpoint subdomain.

I read that there might be a DNS caching problem, but I am unaware of any way to reset the button and I've tried waiting to see if the cache would correct itself.

Does anyone have any suggestions for what to do next?

  • 1
    Have you tried resetting it (hold the button for 15 seconds) then reconfiguring it with your new network? Also, beware of typing out the wrong subdomain — someone else had a similar issue caused by transcribing it incorrectly, so copying and pasting might be best. – Aurora0001 Dec 20 '17 at 20:08
  • 2
    Thank you for the help on resetting the device, I hadn't found that yet. I just tried to reset and then reconnect to the correct wifi, but I'm still getting the same error. – Swagin9 Dec 20 '17 at 20:23
2

Try to reboot your router and check your settings on it to see if anything has been changed in your DNS Settings.

The issue usually goes away for a few weeks but I am unable to find a reason why it does that. I have a Linksys router and have been having issues with DNS and it's on devices such as printer not just IoT Devices.

Also check your certificate, private key, endpoint sub-domain, and endpoint region to see if they match your AWS IoT Console settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.