11

So I installed mosquitto and mosquitto-client on a Raspberry Pi running Raspbian Jessie through apt-get as well as mosquitto on another Pi running Arch Linux through pacman. On Arch the client utils do not need to be installed separately.

Testing simple subscription/publishing on Raspbian worked out of the box.

mosquitto_sub –d –t blub
mosquitto_pub –d –t blub –m “test”

Publishing from the Arch box works as well:

mosquitto_pub -h <IP-Raspbian> -t blub -m "test"

Subscribing a topic on the Arch system however gets me just:

mosquitto_sub –d –t blub
Error: Connection refused

Now that is pretty generic. What's wrong here?

10

Turns out there is no broker running on the Arch system whereas installing mosquitto on Raspbian automatically starts it. Simply enable and start the broker.

Start the systemd service.

systemctl start mosquitto

Enable the systemd service to run on boot.

systemctl enable mosquitto

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.