0

I have an issue- which I guess is has some power issue. I'm using ESP32 and a 3.3v Dual relay.

My code is simple ( switch up and switch down ), and works fine.

The thing is that when all wires are connected between ESP32 and Relays, and then connecting ESP32 to USB cable from a 2A adapter to main, it just wont start ( I have a MQTT message send on boot ), BUT when I first connect ESP32 to power ( same cable, adapter and so on ), and only then connect VCC and GND to relay - all is working fine ( buttons and MQTT ).

I tried it several times, and it is persistent

  • 2
    I'm voting to close this question as off-topic because 1) without a schematic it is insufficiently documented to be answerable anywhere 2) it sounds suspiciously like a duplicate of your other current question iot.stackexchange.com/questions/3324/… and 3) the question asked is about the circuitry surrounding the ESP32, and not about the usage of the ESP32 for an IoT purpose. – Chris Stratton Aug 25 '18 at 22:43
  • It is not the same question, and now I’m trying with esp32 board and it has different behavior. What schematic do you need? It is a 4 pin connection ( vcc gnd in1 in2 ) – Guy . D Aug 26 '18 at 3:21
  • You need to show the connections of the relay to the ESP32. And it likely is the same question - the most likely explanation is that your relay input is mis-configuring the ESP32 boot pins. But regardless of that, the question is off topic here as it is not about IoT. – Chris Stratton Aug 26 '18 at 3:35

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.