0

I want to send AT commands from the Arduino serial monitor window to an esp8266. When I upload the program there is no response.

New contributor
user10861915 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

put on hold as too broad by Bence Kaulics, hardillb, Helmar Jan 16 at 9:27

Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. Avoid asking multiple distinct questions at once. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 4
    What have you tried to solve the problem so far? Because there are a couple of basic debugging steps like checking baud rates, or commands should end with \r\n, power supply is suitable, boot configuration is set correctly, etc.. There are plenty of resources about them on the web as "esp8266 AT commands not responding" is not that unique problem. – Bence Kaulics Jan 14 at 11:20
  • Check your library installation and update the packages connect the gpio pins correctly and then check your router connection enter the right ssid and password in program then checkout the result.. Goto arduino.cc and copy the link from there and paste it in arduino IDE and then update the packages.. – Arockia Jegan Jan 14 at 15:10
  • i have updated the packages and installed library but there is no response in the serial moniter – user10861915 Jan 15 at 6:21
  • I was having troubles with ESP8266, one thing that helped me was to use ESP-12 NodeMCU as it doesn't need as many cables and easy install. Take a look also, specially when starting – pb772 Jan 15 at 6:22
  • any other solution for getting response in serial moniter – user10861915 Jan 15 at 11:54

Browse other questions tagged or ask your own question.