3

I upgraded my v1 SmartThings Hub to the v2 SmartThings Hub. According to some online forums, I made sure to properly reset and remove all of my devices from my previous hub. Next, I installed my new hub (v2) and removed my old hub (v1) via the online portal (Groovy IDE or something...). Finally I began adding my devices, most were from the previous hub, a few were brand new that I bought with the v2 hub.

None of the "Samsung SmartThings" devices connected. I've realized that all of the devices that have successfully connected to the v2 hub are Z-Wave, so I can assume that there is an issue with the Zigbee devices or the Zigbee radio in the v2 hub. Since half of them connected on the old hub, I'm assuming it's with the hub's radio.

3

After close to three months of communicating with Samsung support.... I finally received some steps to solve my issues, but I'll step through what they had me do.

Reset Your Hub

  1. Unplug your hub from DC power
  2. Remove all backup batteries from your hub
  3. Wait about 15-30 mins for all capacitance to dissipate
  4. Plug your hub back into DC power
  5. Wait for the LED light to turn solid green
  6. Try to add your device(s)

Reset Your Device

There are a number of guides that Samsung provides for each device on how to properly reset your device. The latest SmartThings app provides a link that takes you directly to the appropriate page when it appears to be taking too long to connect.

For the most part, it consists of either pressing and holding an available connection button for 5 seconds until the LED begins blinking green or blue. An alternative, typically for older models, is to remove all power from the device (battery, plug, etc.) press and hold the connection button while re-introducing power to the device. Continue holding the connection button until the LED begins flashing red or yellow at which point you should release the button.

Verify Your Radio

  1. Log into your SmartThings Groovy IDE using either your SmartThings or Samsung account (whatever you log into your app with).
  2. Go to My Hubs
  3. Look at the row for ZigBee.

    a. Verify the State: Functional

    b. Verify the OTA: enabled for all devices

For me, OTA was disabled, if this is the case scroll down to Utilities and click on View Utilities and follow the next few steps:

  1. Look at the row for ZigBee Utilities
  2. If you have no utilities, perform the Soft Reset on Your Hub
  3. Click on the Allow OTA tool
  4. Go back to My Hubs
  5. Verify the OTA setting is now set to enabled for all devices*

Soft Reset on Your Hub

When verifying the configuration of my ZigBee radio, I did not have any utility options for my device. So, I was instructed to perform what they called a Soft Reset of my hub.

  1. Unplug all power (DC and battery) from the hub
  2. Using a small tool or paperclip, press and hold the reset button in the back
  3. While continuing to hold the reset button, plug the DC power back into the hub.
  4. When the LED begins flashing yellow, release the reset button. For me, the light almost immediately began flashing as soon as I plugged in the DC power. Also, the flashing wasn't a normal flash, it looked like a glitchy "my battery is about to die kind of flash". For those that remember how the LED indicator light would flash on the Gameboy, that's what it's like.
  5. The hub will go through a series of updates, transitioning the LED light between blue, magenta (or pink), and off.
  6. When the hub is ready, it will return to a solid green.
  7. After the hub is ready, return to the online portal and run through the steps for verifying and setting the OTA configuration to enabled for all devices.
|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.