4

I'd like to access my Wi-Fi Socket (Smart Plug SWA1) at home from anywhere via my (Android) Phone. It works perfectly at home via Wi-Fi. But when I tried it from outside, it didn't.

Even if it says "accessible via 2G/3G/4G/Wi-Fi". Doesn't that mean, it's also accessible via a phone? I used then the "Advanced IP Scanner" but it doesn't listen to any port. So I can't forward any ip/port pair at my Fritz!Box 7490 since it obviously doesn't use any daemon. I'm able to ping it from the home net.

Even if I don't want to use Alexa or so, I wanted to try the efamilycloud app on my phone, just for fun, but it even wasn't able to accept a correct password.

So I thought of something like a Wi-Fi proxy?

Anyone any idea?

  • Well the efamilycloud app seems to be their way to control it. Have you tried resetting the password? Allowing the plug to be accessible via proxy from the outside without some kind of authorization might not be the best option. – Helmar May 5 '19 at 10:07
  • 1
    Most IoT devices that can be accessed remotely use an always-connected cloud model, where the IoT device maintains a connection with a remote server, or polls periodically. This avoids the need for port forwarding or relying on UPnP, which is a little better in terms of security (not having a port exposed to the world). You should check the app to see if remote access must be enabled first, as it is often not on by default. – multithr3at3d May 5 '19 at 14:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.