I would like to use my Xiaomi Gateway v2 EU-Version with openHAB. In order to do that I need to enable the developer mode in Xiaomi MI Home app. These are the full instructions from openHAB:

1.  Select your Gateway in the MiHome app
2.  Go to the "..." menu on the top right corner and click "About"
3.  Tap the version number "Plug-in version : 2.XX.X" at the bottom of the screen repeatedly until you enable developer mode
4.  You should now have 2 extra options listed: `wireless communication protocol` and `hub info`
5.  Choose `wireless communication protocol`
6.  Tap the toggle switch to enable WiFi functions. Note down the developer key (aka password), something like: 91bg8zfkf9vd6uw7
7.  Make sure you hit the OK button (to the right of the cancel button) to save your changes

I'm stuck at #2: Go to the "..." menu on the top right corner and click "About" - there is no About menu. I tried switching the region from Germany to China but with the same result.

How to enable the developer mode in Xiaomi Mi Home App? Any ideas welcome.

2 Answers 2


According to this forum, in the newest version you are :

no longer able to activate the Dev Mode

However you can :

replace the Xiaomi Hub with a CC2531 USB sniffer that enables you to communicate directly via Zigbee with your Xiaomi sensors.

  • Thanks for you reply. Would it be possible to use an older version of the Xiaomi Mi Home Android app to activate the Dev Mode?
    – Tom
    Aug 18, 2019 at 8:17
  • 1
    I assume so if you can find a download Aug 18, 2019 at 18:30
  • I tried it with multiple old versions of the app, didn't work for me. (if anybody else want to give it a shot: old Mi Home versions are available on apkmirror.com)
    – Tom
    Aug 20, 2019 at 10:01
  • remember if using apkmirror.com you will need to be disable androids only download from play store settings. Aug 26, 2019 at 9:03

On my manual there is a sticker with the code also on the HUB But the code on the manual (HUB) is with 8 numbers 4 x 4 You have to put it into HA as xxx-xx-xxx and that works for me !

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.