1

Got a new router from the ISP and my ESP8266 NodeMCUs are causing problems, they need very long to connect to WiFi (3-4 mins), which wouldn't be that big of a problem, but they also don't connect to the MQTT Broker (I am running OpenHAB2 on a Raspberry Pi(Ethernet) and MQTT Broker). "Attempting to connect to MQTT Server..." is printed forever.

OpenHAB and Raspberry are working fine, I can send/recieve MQTT messages and can also send/recieve messages to OpenHAB from my notebook with the MQTT.fx client.

Since I didn't change anything in the ESP8266 code (mostly Arduino FastLED code) and it worked fine with the old router, I assume the code is OK and the solution needs to be somewhat with the new Router?

Anyone any idea what I could try? The router is a noname product (the ISP just prints his logo on it) like the old one was, the router setup page is nearly same like the old one, both provide DHCP settings.

I tried to give the ESP a reserved IP but it didn't help.

Thanks in advance.

  • 4
    Without knowing a lot more about the entire setup it's going to be nearly impossible to help here. My best guess is that it's a 2.4Ghz vs 5Ghz issue. – hardillb Oct 12 '19 at 22:08
  • 1
    start by soving the ESP8266 connection delay .... use a simple test sketch to figure out what breaks it – jsotola Oct 13 '19 at 2:00
  • 1
    Please provide more information via edit, otherwise this will be impossible to answer. – Helmar Oct 13 '19 at 21:56