0

I have read through a few blogs and watched videos of setting up the R3. What I have accomplished to date is the following:

  • Paired the R3 with ewelink cell app. I can turn it on and off from the app.
  • I have a jumper on the pins to put the R3 into DIY mode
  • Updated the firmware to version 3.6.0

I see according to the sonoff documentation there is a REST API where I can flash the firmware with a HTTP call. However I was not able to access any of the rest endpoint. I tried using 192.168.1.1XX(I have only allowed 4 devices on the network via DHCP) Does the wifi SSID need to be ITEAD-XXXXXXXXXX. I have the SSID set to sonoffDiy as per another set of documentation.

sonoff reference documentation I am referring to -> http://developers.sonoff.tech/sonoff-diy-mode-api-protocol.html

2

I've struggled with the same this morning, and finally managed to enter DYI mode following these steps:

===========

Start here with 3.5

  1. On the Sonoff device press button for 5 seconds (light pattern changes)
  2. Press button again for 5secs (light pattern changes again)
  3. Connect to the isteadxxxx AP using pwd 12345678
  4. Browse to http://10.10.7.1
  5. Enter your SSID and pwd for your network- case sensitive and hit Save
  6. Wait for device to reboot

=========

Important to mention,that it looks like there is NO MORE NEED for the jumper.

This worked for me with Sonoff Basic R3, version 3.6

Taken from here

2
  • Will try that this evening. Pardon the silly question but do you think any AP name can be used? Also browsing to 10.10.7.1 is that from any device attached to the AP? – user3465651 Aug 27 '20 at 7:51
  • Also if you are able to pair with the eWeLink app, it'll have received the wifi SSID and pwd? – user3465651 Aug 27 '20 at 14:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.