It seems that my Mi Home app is not recognizing the Xiaomi Smartmi Electric Heater 1S. This is actually happening with two different Xiaomi heaters (same model). What I've tried so far, after restarting the heater several times:

  • Scanned for devices nearby
  • Manually added the heater by choosing the "Smartmi Smart Convector Heater 1S" in the devices page
  • Scanned the QR Code on the instructions manual
  • Attempted with a 2.4 GHz and a 5 GHz WiFi
  • Used a hotspot from a 4G mobile network
  • Connected to the heater's WiFi network directly
  • Tried with a Xiaomi Pocophone F1 mobile phone, a Samsung S6 tablet and a Honor mobile phone (all with location services and bluetooth enabled)
  • Tried with two different Xiaomi accounts on the Mi Home app

Anything that I might be missing here?

Thank you.

EDIT - I changed the region for my Mi Account to China Mainland and I was able to pair the heater, but when attempting to open it in the app, I get the below error: enter image description here

  • I'm going out on a limb here, but have you tried using a VPN? I wonder if they're detecting from your IP that you're not in the country you've selected and are blocking you in consequence.
    – anonymous2
    Commented Nov 14, 2020 at 12:59
  • Oh and you could also try setting your DNS server to (China) on your router.
    – anonymous2
    Commented Nov 14, 2020 at 13:01

2 Answers 2


I have had the same issue. I tried VPN and DNS, but could not make it working. I have had the information from another website, you have to uninstall Xiaomi Home (probably rev 6...) and install old Xiaomi home (I tried 5.6.10 from 2019) and it worked. Only thing, think to remove the automatic application update in Playstore, because during the night I got update and had the same message error (and had to do same process again). I spent so much time to solve this, I want to share my happiness.


To work around the 'region not supported' error message in version 6 of the app, I suggest temporarily changing the time zone to China (in the settings of the device running the app)

  • 1
    Have you checked that setting the time zone is sufficient?
    – Helmar
    Commented May 31, 2021 at 8:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.