1

I have a Nordtronic dimmer installed in the bathroom. It is connected to Home assistant via Zigbee, but it is also connected to the physical light switch.

Is it possible to set this up, such that if I turn it on with the switch, at night it will go on in a dimmed state, and during the day it will be bright? And if so, how?

2 Answers 2

2

Sounds like you just need a device that will be on the same network and send out a message at say, 7PM and at 6AM, with the right brightness value. The light switch would have to send a message for just the state (on/off).
The device that sends out the brightness message could be a RaspberryPI on the same network, for example. The Pi can get the current time (and month) from a time service API. Just use a fixed sunset, sunrise time for each month for your latitude. If you want to get fancy, that Pi device can get sunrise and sunset time for the current day via API and use that.
See https://www.programmableweb.com/news/top-10-time-apis/brief/2020/03/08 for various APIs. You can even see if the moon is out and shining thru a skylight and adjust brightness! :-)

I hope the current light switch is not powering off the Nordtronic dimmer or running a parallel wire to the light switch !

1
  • Thanks for the answer. I have most of this in place already, I'm just trying to figure out how to use it. The switch is wired correctly, it just sends a signal to the dimmer which always has power and I have Home Assistant running on a Raspberry. I'm not sure if the dimmer will accept a brightness change when it is off, but I think I can try with Mosquitto broker. I'll update here if I find out more.
    – Orbit
    Jan 15, 2022 at 10:47
0

It looks like the solution was right in front of me all along. In the sheet from the link in the question: "NOTE: brightness move/step will stop at the minimum brightness and won't turn on the light when it's off. In this case use brightness_move_onoff/brightness_step_onoff".

The brightness_move command was not available for this device in automations, but I have set it to call a service instead, and send out a MQTT message: "brightness_move": -40. This has worked so far.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.