I have a Chamberlain MyQ home bridge that was successfully controlling our garage door opener (equipped with an 888LM MyQ control pad) for years, until last Tuesday when we performed the HomeKit "upgrade" after installing iOS/MacOS/iPadOS/tvOS 16.2 on everything.

All of the dozens of HomeKit things in both our homes survived the upgrade just fine, all except for this MyQ bridge.

Now it will work for about a minute after it is power cycled, but then all of the devices behind it will go into "not responding" state. I added an old Liftmaster lamp switch as a test and it goes into "not responding" at the exact same moment as the garage door.

Everything still works just fine with the MyQ app on the phone, just not in HomeKit. Of course, HomeKit connectivity was the precise and only reason I bought this in the first place.

So what did Apple change with this architecture upgrade? What can I do to further troubleshoot why this bridge seemingly falls out of HomeKit a minute after it comes up?

  • Obviously you shouldn't have to do this but have you tried removing the bridge from your home and re-adding it?
    – romkey
    Dec 18, 2022 at 4:12
  • What Apple changed is that the Home app now makes requests just to the Home hub, and the hub talks to individual devices rather than the Home app. Each instance of the Home app used to talk to all the devices directly. This reduces network traffic and load on under-resourced devices. You might also try rebooting/power cycling whatever device is functioning as the Home hub for you.
    – romkey
    Dec 18, 2022 at 4:14
  • 1
    I have tried removing and re-adding the bridge many times and even factory-reset it and started over. No help. I have also power-cycled all of our Apple TVs multiple times. No help there either.
    – nsayer
    Dec 18, 2022 at 17:12
  • Attempting to update one of our Apple TVs to the 16.3 beta and forcing it to be the active bridge didn’t help either.
    – nsayer
    Dec 19, 2022 at 5:45
  • I would never suggest installing beta code in order to solve a problem unless Apple tech support told you to. That way lies madness.
    – romkey
    Dec 19, 2022 at 17:04

1 Answer 1


Either updating two of the Apple TVs to the 16.3 beta and waiting a few hours, or bouncing all of our (three) homepods and waiting a few hours seems to have fixed this. The garage door has been online and functioning within HK just fine for about 12 hours now, so I am going to declare victory.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.