0

ESP - IDF not functioning as expected. I've been trying to work on esp32s3 and skainet using esp-idf(ide not the eclipse or vs code plugin) and I am facing this issue constantly. Issue: I have made a project but and at times the idf doesn't recognize or include the header files and states they are missing even though they are included and when it includes the header files the it doesn't recognize it's contents.

Ex I enable ble 1. it doesn't include the header files and says they are missing. 2. if it includes them then it doesn't recognize their content i.e if the definition and structure of a function or variable is given then it then it display the variable first used here and not defined. I've tried different methods and approaches like manually placing them, editing the cmakelists.txt and trying the example codes given by espressif on github but it is the same for them also it's not working even in their code. I was expecting it to work atleast for their code so I can take reference and work or make changes accordingly but to no avail. I also tried using it via terminal but still it is the same. I am still not clear if it's the cmake file or anything else but if it is possible then please explain.

1
  • 1
    which part of your post is about a problem with voice recognition? ... which part is about smart home?
    – jsotola
    May 20, 2023 at 5:33

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.