I'm having a weird behaviour of Tasmota (v.13) on 82866 devices, that hang up spontaneously (happens at different times, for different durations). For example, they can be connected for 12 hours and disconnect for 2 hours, and another time can be connected for 2 hours and disconnected for 15 minutes.

My setup:

  1. My house is rather small, and distance from IoT device to the router does not exceed 7 meters. WiFi signal is 3 out of 4 reception bars. So reception is fairly good.

  2. When using my old Edimax router (it was dedicated for IoT devices) everything worked flawlessly.

  3. This behaviour started when I switched to a TPlink router. To be on the safe side, the router was reset to factory settings. Before that reset, when disconnection happened - reconnect would happen only after rebooting the router, and not the IoT device.

  4. To be sure that is it not the IoT device, I took another Tasmota device (new, same version, much closer to the router - 2m).

  5. When disconnection happens it occurs on both devices almost simultaneously. (I monitor it using home assistant). So the IoT device is not the problem.

  6. I even disabled the 5Ghz band to be sure it is not anything the AC channel. Problem persists.

  7. During that disconnection periods there were no ISP or LAN/WiFi problems.


  1. I know for sure that IoT devices are not the problem (worked OK when was connected to old router).

  2. Scanning neighbouring WiFi networks does not show any problems/ overlap of others.

  3. TP-Link router works OK (LAN and 5Ghz Wifi for sure). Firmware is up to date. But there for some reason, there is a timely disconnection, that prevents a significant reconnect (10's of minutes and sometime more than an hour).

  4. After factory reset - that behaviour is less significant (disconnection period was much longer - can reach hours ), but still happens.

I'll be happy for any leads that can be provided here.

  • 1
    Are any of these helpful ? community.tp-link.com/en/home/forum/topic/196026?replyId=444740 My guess is the DOS protection, though I wish they have a way to turn it off on the wifi side. Commented Dec 25, 2023 at 17:32
  • it is certainlly a good lead - but what may cause a router to block connection almost simultenouly for 2 out of 2 tasmota devices ? old router did not block the entire traffic
    – guyd
    Commented Dec 26, 2023 at 16:28
  • See the last few items in the discussion I linked to. DHCP leases being rounded out and eventually, renewal being attempted around the same time from multiple devices. See if turning off DOS protection helps. Commented Dec 26, 2023 at 16:42
  • there is no such item in any menu... How else can be called ?
    – guyd
    Commented Dec 27, 2023 at 12:23

1 Answer 1

  1. Its not only the distance it is the obstacles, wall materials as concrete, metal can shorten the distance considerably.

  2. The lower bandwidth used by older routers (amongs other your edimax) is more sturdy.

  3. Have you change the location/orientation on your TP-link? And there is a phenomena called micro black cells, that is small areas where the reception is worse and by moving the device just 10-20 cm can change the reception considerably.

  4. Check for firmware upgrades again.

A bit more far fetched

  1. Heat issue?

  2. Does the TP-Link AX1800 have any automatic "retraining" of the radio that can be disabled?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.