9

I am trying to get a Wemo Smart Switch/Plug to work with Amazon Echo Dot. I have Amazon Echo Dot installed configured and working normally. I have installed the Wemo App on an iPhone. Using the iPhone I installed and configured the Wemo Smart Plug. I can control the smart plug using the iPhone application.

Now I want issue on/off commands using Amazon Echo Dot. I am unable to integrate both Amazon Echo Dot and Wemo Smart Switch/Plug. Below is an image of the Wemo Switch.

Wemo smart plug

I am using the Alexa web interface to configure the Amazon Echo Dot. When I try to enable skills per the below image, I am unable to enable the skills.

wemo skill in alexa app - activation screen

The application presents a UI as below, but I am unable to proceed any further.

wemo login screen

Per my research I have tried to enable remote access using the following menu option.

wemo settings

When I try to enable remote access I get the following error

Sorry, we were unable to setup your remote access just now. To try later go to More > Remote Access

Also on my Alexa Echo Dot interface Home > Smart Home > Your Devices > Discover Devices the application Echo Dot successfully discovers the Wemo Switch.


Question: What am I missing?


Sources referred are:

  • 1
    Great question! Welcome to Internet of Things Stack Exchange! If you want, I can implement the links you provided in your post. – anonymous2 Feb 7 '17 at 21:28
  • User8055, are you sure you have successfully added the Wemo skill to your Alexa app? – anonymous2 Feb 7 '17 at 21:42
  • @anonymous2, Yes I Alex App recognizes the Wemo Switch – user8055 Feb 7 '17 at 21:54
  • @user8055 I went ahead and update the links. Also I suggest reducing the image sizes. – Mahendra Gunawardena Feb 7 '17 at 23:25
  • If your Alexa App already discovers the switch, doesn't it work already? If it has a name in the app you should be able to voice control it. – Helmar Feb 8 '17 at 18:17
4

I can think of two possibilities:

  1. Uninstall the Alexa app and re-install. It sounds to me like the Alexa app is having the trouble. I had a problem with it on my iPad and had to uninstall it, then install it again fresh. After the reinstall, everything worked normally.

  2. Maybe forget the switch via the Alexa app, then try the account linking again. Did you do the device discovery through the app, or via voice by asking Alexa to "scan for devices"? It's odd it sees your devices yet it won't let you link the accounts. Just an idea.

| improve this answer | |
  • Thank you for the response. I followed your suggestions. But I still unable to get Alexa to work with the Wemo Smart Switch. As I understand I need to get Remote access enabled which I am unable to get pass. – user8055 Mar 2 '17 at 21:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.