Episode #125 of the Stack Overflow podcast is here. We talk Tilde Club and mechanical keyboards. Listen now

Questions tagged [mosquitto]

For questions concerning Eclipse Mosquitto, an open source MQTT broker implementation, including setup questions, issues with running the broker, and questions about the behaviour of Mosquitto.

6 questions with no upvoted or accepted answers
Filter by
Sorted by
Tagged with
5
votes
0answers
205 views

Offline messages not being send to Adafruit IoT portal by Mosquitto broker

I have a Raspberry Pi in which I have installed Mosquitto broker and MQTT. Pi is connected to sensor and I need to send this data to Adafruit IoT protal. I am able to send all the data when the Pi is ...
3
votes
0answers
51 views

What IoT services are available for free that does not have message rate limit?

let say my other device publishes messages every 10ms (trying to show a real time graph in mobile app) sending at slower rate i.e every 1s instead of 10ms would result to wrong output. Are there any ...
3
votes
1answer
112 views

Why does Mosquitto not apply access lists correctly?

I tried to apply an access list to a user, but Mosquitto always takes the highest access level and apply it. I tried to apply this: user roger topic readwrite device/1/# topic read device/1/name/ I ...
2
votes
1answer
17 views

Why does MQTT Broker forget connection from SIM800 module?

I am working on SIM800 module and MQTT broker (Mosquitto) to design a kind of IoT device. When i try the MQTT server, i encountered this problem. The SIM800 connects MQTT server on TCP connection. You ...
2
votes
0answers
500 views

Mosquitto service won't start

I have an AWS EC2, Ubuntu-16.04 instance where Mosquitto is installed. I noticed that, the mosquitto process dies out and nothing apparent seems to be appear in the log /var/log/mosquitto/mosquitto....
1
vote
0answers
94 views

Why is Mosquitto broker and Paho client running CPU 100% on connection?

I would like to use the mosquitto MQTT broker using Websockets. I am running mosquitto version 1.6.2 on a Debian 8 server. "normal" MQTT works fine, but I am having a problem trying to connect using ...